Google Cloud Platform down
Incident Report for Concentric
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 18:15 GMT
Investigating
Google Cloud Platform services are currently down, affecting a large number of websites and applications including Concentric. We await an update from GCP regarding resolution.
Posted Nov 16, 2021 - 18:05 GMT
This incident affected: Clinician application and Patient application.