Concentric application down
Incident Report for Concentric
Resolved
This incident has been resolved with all systems now expected to be fully operational.
Posted Jun 11, 2023 - 14:39 BST
Investigating
We are aware that Concentric is currently down and it is not possible to access the login page or any patient records. We are investigating the issue.
Posted Jun 11, 2023 - 14:15 BST
This incident affected: Clinician application and Patient application.